
FastPACS WebWorkstation 
Build Instructions

Windows 7 with IIS 7.x

Precision Diagnostic Systems, Inc.
2N353 Landrose
Maple Park, IL   60151 USA
(630) 365-1123
www.precisiondiagnostic.com

Company Confidential - 
Internal Use Only

http://www.precisiondiagnostic.com
http://www.precisiondiagnostic.com


TABLE OF CONTENTS

..............................................................................................................NOTICES! 3

NOTICE OF CONFIDENTIALITY! 3

SCOPE OF THIS DOCUMENT! 3

.....................................................................ARCHIVE INSTALLATION PART 1! 4

.......................................................FASTPACS WEB SERVER INSTALLATION! 8

...................................................................................iQ-VIEW INSTALLATION! 25

...................................................................ARCHIVE INSTALLATION PART 2! 26

................................................INSTALLATION OF HELPER APPLICATIONS ! 29

MICROSOFT ACCESS AND EXCEL! 29

DICOM PING! 30

CREATE A SECURE SELF-SIGNED CERTIFICATE! 31

DICOMREADER! 34

DAILY BACKUP! 37

OTHER ITEMS! 39

..................................................................................................CLEANING UP ! 40

COMPANY CONFIDENTIAL! Page 2



NOTICES

NOTICE OF CONFIDENTIALITY

The contents of this document including all methods, descriptions, text, images, designs and operations 
displayed and/or described herein are proprietary and company confidential. No content of this document 
may be transmitted by verbal, written, electronic or any other method of communication to any person or 
entity outside of Precision Diagnostic Systems, Inc. Any unauthorized release of this information by any 
means is prohibited and punishable by law. This means you. 

Copyright 2013 Precision Diagnostic Systems, Inc.

SCOPE OF THIS DOCUMENT

This document describes the procedure to build FastPACS WebWorkstation specifically on a computer 
with Microsoft Windows 7 Professional Operating System and Internet Information Services version 7.x. 
This document only applies to WebWorkstation and does not apply for an installation of FastPACS on 
Windows Server or other configurations. This document assumes the computer Operating System is 
already installed and configured. Note that some screenshots are from Windows XP systems but 
instructions will apply to a Windows 7 installation unless otherwise noted.

Failure to execute these procedures in the order presented may produce unpredictable results.

Initial Release:! ! 1/2013
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ARCHIVE INSTALLATION PART 1
This step is for 32-bit installations only: From the latest Distribution, drag the bdinstall5 folder to the 
desktop of the target computer. Double-click the folder to open it and launch “Setup.exe” to install the 
Borland Database Engine. As of this writing bdinstall5 will not install on 64-bit systems. Skip this 
step if the target system is a 64-bit system. Without bdinstall5 installed, searching the Conquest 
database by Patient Name within Conquest Server will not be possible but searching by Patient ID 
can be done. The lack of the Borland Database Engine does not affect the interaction with other 
DICOM devices or workstations.

Note: There are two “setup” files in this folder. Launch the one with the computer icon, not the one with 
the icon of the globe. 

Accept the default values for the installation and allow the installation to finish:

Move the bdinstall5 folder from the desktop to the recycle bin.
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ARCHIVE INSTALLATION PART 1 (cont.)

From the latest Distribution, drag the “dicomserver14xx” folder directly to the root of the C: drive of the 
target computer:

Open the C: drive and rename the folder “dicomserver14xx” to “dicomserver”:

Open the c:\dicomserver folder and double-click ConquestDICOMServer:  

In the window that opens, choose “Built-in DBASEIII without ODBC (*DBF)” from the drop-down menu 
and click “OK”.
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ARCHIVE INSTALLATION PART 1 (cont.)

The server configuration window will now open.

Make the following changes:

* Change DICOM Server AETitle from CONQUESTSRV1 to FPSRV1
* Change TCP/IP Port Number from 5678 to 5680
* Under “Images on disk are stored:” Click on “Uncompressed”
* Under “Images on disk are named:” Click on “DCM (standard format)”
* Click in box “Keep Server Alive”
* Click the “Save configuration” button
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ARCHIVE INSTALLATION PART 1 (cont.)

The DICOM Server will now switch to the “Installation” Tab:

Do the following:

* Click “Verify TCP/IP installation”
* Click “Verify database installation”
* Click “(Re) initialize database

 

If no errors are present after doing each step outlined above, close the dicomserver window. This will quit 
the dicomserver application. Click “Yes” to the alert box:
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FASTPACS WEB SERVER INSTALLATION
The installation of Internet Information Services (IIS) 7.x is required:

Go to Start => Control Panel. Select “Programs and Features”, then click “Turn Windows Features on or 
off”. Select the following IIS components to install:
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FASTPACS WEB SERVER INSTALLATION (cont.)

From the latest Distribution, drag the “DIOWave” and “DIOWaveData” folders directly to the root of the C: 
drive of the target computer:

  

Click on “Start” then choose “Run” (below left). Type cmd in the window that opens. (If “Run” is not in the 
start menu, right-click on “Start” and choose “Properties”. Choose the “Start Menu” tab then click 
“Customize”. Scroll through the list and place a check mark next to “Run command”, then click OK.)    

Type the following commands (shown in bold below) following the C:\> prompt in the DOS window that 
opens. Note that there is no space between “binPath” and “=”:

sc.exe create "DIO_STORAGE" binPath= "C:\DIOWave\bin\dio-storage.exe"
(It should respond "[SC] CreateService SUCCESS")
sc.exe start "DIO_STORAGE"
(It should respond with the Service Name and other info)

Your window should look similar to the following:

  
You have created the service that allows the FastPACS Web Server to receive DICOM images. You may 
close the window.

COMPANY CONFIDENTIAL! Page 9



FASTPACS WEB SERVER INSTALLATION (cont.)

Now set the service you have just created to automatically start upon boot and recover from errors:

Go to Start => Control Panel => Administrative Tools => Services.

Locate “DIO_STORAGE” in the list, right-click it and choose Properties:

Under the General tab, change Startup Type to Automatic (below left). Then select the Recovery tab 
(below right) and change the setting of First Failure, Second Failure and Subsequent Failures from “Take 
No Action” to “Restart The Service”:

Click “Apply” then click “OK”. Close out the open windows.

Go to Start => Control Panel => Folder Options

Click the “View” tab and Deselect both “Hide extensions for known file types” and “Use Sharing Wizard 
(Recommended)”. Click “Apply” then “OK” and close out the open windows:
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FASTPACS WEB SERVER INSTALLATION (cont.)

Go to Start => Control Panel => Administrative Tools => Internet Information Services to launch the IIS 
Manager. 

Click the “+” next to the Computer Name then click the “+” next to Web Sites to reveal “Default Web Site”.

Right-click Default Web Site and navigate to New => Virtual Directory:

This creates /DIOWave = C:\DIOWave\wwwroot (Read document)

Enter Alias DIOWave
Enter Physical Path c:\DIOWave\wwwroot
Click “OK”
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FASTPACS WEB SERVER INSTALLATION (cont.)

Right click on DIOWave and navigate to New => Virtual Directory:

This creates /DIOWave/scripts = C:\DIOWave\scripts (Executable for ISAPI)

Enter Alias scripts
Enter Physical Path c:\DIOWave\scripts
Click “OK”
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FASTPACS WEB SERVER INSTALLATION (cont.)

Right click on DIOWave and navigate to New => Virtual Directory:

This creates /DIOWave/StudyBrowser.NET = C:\DIOWave\webapp\StudyBrowser.Net (Executable for 
scripts)

Enter Alias StudyBrowser.NET
Enter Physical Path c:\DIOWave\webapp\StudyBrowser.NET
Click “OK”
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FASTPACS WEB SERVER INSTALLATION (cont.)

Right-click on the StudyBrowser.NET Virtual Directory and select “Convert to Application”:

Click “Select” in the window that opens. Then choose “Classic .NET AppPool” from the drop down menu:

Click “OK” to close out the open windows.
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FASTPACS WEB SERVER INSTALLATION (cont.)

The following steps must be taken to allow the required .dll extensions to run.

In IIS Manager, check that “Features View” is selected. Single-click the scripts Virtual Directory then 
double click “Handler Mappings”:

You should find “ISAPI-dll” disabled. Single-click it to select it:
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FASTPACS WEB SERVER INSTALLATION (cont.)

Then click on “Edit Feature Permissions” on the Actions pane on right:

Place a check mark in the “Execute” box then click “OK”:
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FASTPACS WEB SERVER INSTALLATION (cont.)

Locate ISAPI-dll in the list, which should now be Enabled. Single-click it to select it then click “Edit...” in 
the Actions pane on right:

Enter the path of c:\DIOWave\scripts\dio-image.dll. Click “OK”. Then click “Yes” to the “Do you want to 
allow this ISAPI extension?” alert box that opens:

Once done, you can close IIS Manager.
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FASTPACS WEB SERVER INSTALLATION (cont.)

Special privileges must now be assigned for unique User Accounts on certain directories. 

Do the following:

In Windows explorer go to C:\DIOWave, right-click on the folder and select Properties.
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Select the Security Tab then click Edit: Then click Add:

Then click Advanced: Click Find Now:



FASTPACS WEB SERVER INSTALLATION (cont.)
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Select IIS_IUSRS from the list then click OK:

Repeat the same procedure to add users named IUSR and NETWORK 
SERVICE. Give each of these users “Modify” rights to the DIOWave folder. 
Once this is done do the same procedure for IIS_IUSRS, IUSR and NETWORK 
SERVICE users on the DIOWaveData folder.

Now give this user Modify rights and click “Apply”:



FASTPACS WEB SERVER INSTALLATION (cont.) 

REDIRECT HOME DIRECTORY: !

Launch IIS Manager and single-click Default Web Site in the Connections pane. Then click “Basic 
Settings”:

Enter the Physical Path of c:\DIOWave\webapp\StudyBrowser.NET and click OK:
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FASTPACS WEB SERVER INSTALLATION (cont.)

SET DEFAULT DOCUMENT:

Single-click the computer name in the Connections pane then double-click “Default Document”:

Move default.aspx to the top (or click “Add...” and create it if it doesn’t exist). Delete any entries of 
Default.htm and Default.asp that are in this list:
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FASTPACS WEB SERVER INSTALLATION (cont.)

To allow FastPACS to run on 64-bit systems, first single click on Application Pools in the Connections 
pane on the left side. Then right-click on the Classic .NET AppPool in the center pane and select 
"Advanced Settings...". Change "Enable 32-Bit Applications" from “FALSE” to "TRUE". Click “OK”

Right-click on Default Web Site go to “Manage Web Site” => “Restart” to have the change take effect. 

When finished, close out all open windows and Reboot the computer.
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FASTPACS WEB SERVER INSTALLATION (cont.)

Launch Internet Explorer and go to http://localhost. If all goes well you should see something like this:

But some systems have a problem with http://localhost. If you see the following error, use the address of 
http://127.0.0.1 or http://xxx.xxx.xxx.xxx (where “xxx” is the IP of your computer) in your browser and it 
should correct itself:
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FASTPACS WEB SERVER INSTALLATION (cont.)

Quit Internet Explorer and go to c:\DIOWave\webapp\StudyBrowser.NET

Open query.aspx then press Cntl-F to open a “find” window and search for fastpacs

Upon the second occurrence of fastpacs, highlight the words FastPACS Web: 

Replace this text with the name of the customer’s institution:

Now save the document. This personalizes the installation.
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iQ-VIEW INSTALLATION
Launch the iQ-VIEW installer from the desktop of the target computer. Accept the defaults for the 
installation EXCEPT CHANGE THE PORT FROM 104 TO 4000.

With iQ-VIEW running, select the “Network” tab and click the icon in the upper right hand corner that 
appears as 3 networked computers (below left). In the window that opens, single-click to highlight the first 
entry (below right):

  

Enter the new values in the lower part of the window:

Logical Name: ARCHIVE
DICOM AE Title: FPSRV1
IP Address: 127.0.0.1
Port Number: 5680

Click “Change” then click “Save”. You may now quit iQ-VIEW.

Go to C:\Program Files\iQ-VIEW then right-click on iQ-VIEW.exe and select “Pin to Start Menu”. Go to the 
Start Menu and right-click on “iQ-VIEW.exe” and rename this file “iQ-VIEW”.

Go to Start => All Programs => Startup and right-click on Startup. Choose Open. This will open a new 
window. Return to the C:\Program Files\iQ-VIEW window. Right-click and drag on iQ-VIEW.exe and 
move your mouse to the Startup window. Release the right mouse button and choose to place a shortcut 
in the location.

Open the file custom.ini located at C:\Program Files\iQ-VIEW with Notepad. Navigate to the line that 
begins with StudyBrowserForm.StudyGrid.Lines[15]. Remove all text to the right of the equal (=) sign then 
save the file and close it.
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ARCHIVE INSTALLATION PART 2
Navigate to C:\dicomserver and double-click the file dicom.ini (NOT dicom.sql)

Insert the following text at the end of this file:

IMPORTANT: Be sure there is a space both before and after the equal sign (=).

Your file should look like this:

Save the file and close it.

Double-click ConquestDICOMServer.exe:

Select the “Known DICOM Providers” tab:

Remove any existing entries and enter the following:

# Forwarding
ExportConverters!  = 2
ExportConverter0!  = FORWARD TO DIO_STORAGE
ExportConverter1!  = FORWARD TO IQSERVER

IgnoreOutOfMemoryErrors! = 1

FPSRV1! ! ! 127.0.0.1! 5680! ! un
DIO_STORAGE!! ! 127.0.0.1! 104! ! un
IQSERVER! ! ! 127.0.0.1! 4000! ! un
*! ! ! ! *! ! *! ! un
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ARCHIVE INSTALLATION PART 2

The “Known DICOM Providers” window should look like this:

When done, click “Save This List”. 

Now select the “Configuration” tab.

Click the button “Install Server as NT Service” as shown below. Wait several seconds to allow the 
AETitle entry to gray out while a service is being created:

Close the server window. Click “Yes” at the subsequent dialog box.
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ARCHIVE INSTALLATION PART 2

Go to Start => Control Panel => Administrative Tools => Services.

Locate FPSRV1 in the Services list then right-click and choose Properties.

Click the “Recovery” tab and change each entry to “Restart the Service”:

Click “Apply” then click “OK”. Close the open windows. Reboot the computer.
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INSTALLATION OF HELPER APPLICATIONS

MICROSOFT ACCESS AND EXCEL

Now that the Core Applications have been installed, there are several additional applications that must be 
installed and configured.

Insert the Microsoft Office disk, Install Office 2003 (below left), then choose “Custom Install (below right):

    

De-select all items except Access and Excel then click “Next” to proceed with the installation:

Allow the installer to finish then remove the CD. When the installation is finished, be sure to apply the 
Office Service Pack 3 update from the distribution.
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DICOM PING

From the Distribution, drag the DICOM Ping folder to the root of the C: drive of the target computer:

No further installation is necessary.
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Note that the web browser on the client computer will display a Certificate Error 
because the Certificate was created by an untrusted source, but communications will 
still be encrypted and secure. 



CREATE A SECURE SELF-SIGNED CERTIFICATE

A Server Certificate allows encrypted communication between the PACS Server and remote clients. The 
following procedure creates a self-signed certificate for secure communications. 

Launch IIS Manager. Single-click the computer name on the left side then double-click Server 
Certificates:

Click “Create Self-Signed Certificate” in the Action pane on the right side:
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CREATE A SELF-SIGNED CERTIFICATE (cont.)

Give the Certificate a name that makes logical sense for the installation then click “OK”

Single-click Default Web Site on the left side then click “Bindings...” on the Actions pane on the right side:
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CREATE A SELF-SIGNED CERTIFICATE (cont.)

Click “Add” then choose https under “Type” and select the Certificate you created with the drop down 
menu under “SSL certificate”. The SSL Port is 443 by default. If the IT department at the customer site 
requests another port be used, it can be changed here. Click OK when done.

Launch a browser to https://localhost (or https://127.0.0.1) to check for functionality.
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DICOMREADER

Launch the DICOMREADER Installer, accept the default settings, and proceed with the installation:

When the installation is finished, click on the settings tool (it appears as a wrench):

Place check marks next to “start application minimized (as tray icon)” and “ask for new patient data”:
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DICOMREADER (cont.)

Click the DICOM Stations button:

Enter the password: DICOMREADER (in CAPS)

Click “Add” to add a new DICOM destination

Now enter the information for the WebWorkstation Archive:

Alias:! ! ARCHIVE
AETitle:!! FPSRV1
Address:! 127.0.0.1
Port:! ! 5680

  

Click “OK” when finished.
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DICOMREADER (cont.)

Select “ARCHIVE” from the drop-down menu as the default destination then click “OK”:

  

Minimize the DICOMREADER window (below left), then exit DICOMREADER by right-clicking the disk 
icon in the right area of the task bar (below right). Only when you quit DICOMREADER in this manner 
after the initial installation does it permanently save your settings:

  

Go to C:\Program Files\DICOMReader then right-click and drag on DICOMReader.exe. Release and 
select to create a shortcut in this same directory. Right-click on the shortcut and select “Pin to Start 
Menu”. Go to the Start Menu and right-click on “Shortcut to DICOMReader.exe” and rename this file 
“DICOMReader”.

Go to Start => All Programs => Startup and right-click on Startup. Choose Open. This will open a new 
window. Return to the C:\Program Files\DICOMReader window. Right-click and drag on the 
DICOMReader shortcut you have created there and move your mouse to the Startup window. Release 
your right mouse button and choose to copy this file there.
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DAILY BACKUP

This is an application that runs as a Scheduled Task to perform daily backups of the Archive and Web 
databases. This makes recovery easier and less painful in the event of database corruption.

From the Distribution, drag the Daily Backup folder to the root of the C: drive of the target computer. 
Navigate to c:\Daily Backup\Bin\ and open the system.ini file by double-clicking on it.

Check that the last two lines of this file read as follows:

c:\DIOWave\db\ = c:\DIOWaveBackup\db\@Weekday\
c:\dicomserver\data\dbase = c:\dicomserverBackup\data\@weekday\

If they do not, change them to read as above.

Close the open windows.

Now the application must be configured to run as a Windows Scheduled Task.

Go to Start => Control Panel => Administrative Tools => Task Scheduler

Click “Create Basic Task” (below left). Give it the name of “Daily Backup” and a description (below right):

   

Select “Daily” then click “Next” (below left). Set the task to run at a time when the customer is closed and 
not generating images then click “Next” (below right):
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DAILY BACKUP (cont.)

Select “Start a Program” then click “Next” (lower left). Click “Browse” in the next screen (lower right):

  

Navigate to c:\Daily Backup\ then Single-click to highlight “DailyBackup.exe” and Click “Open” (lower left). 
Then click “Next” (lower right):

   

Review your settings then click “Finish” (lower left). Quit the Task Scheduler then relaunch it and click on 
“Task Scheduler Library” to see your scheduled task listed (below right):
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OTHER ITEMS

Adobe Reader.

From the Distribution or via direct download, Install Adobe Reader 9 on the target system. After 
installation, check for proper launch of Adobe Reader by launching iQ-VIEW then clicking on the help icon 
on the main screen:

Adobe Reader should launch. Accept the Adobe Reader license agreement. The iQ-VIEW User Guide 
should now be displayed. Quit iQ-VIEW. Then delete the Adobe Reader and acrobat shortcuts that have 
been deposited on the desktop.

Power Settings.

Go to Start => Control Panel => Power Options and set the system to Never Hibernate and Never 
Standby. Hard Drives should be set to Never Turn Off. The monitor should be set to power save after 10 
minutes. The selected Screen Saver should be “None”.

Remote Access.

Launch Internet Explorer and navigate to www.realvnc.com. Download the free version of the Windows 
executable. After downloading, launch the installer and accept the default settings. At the end of the 
installation click the “Configure” button and type pdsisupport as the password in the two entry areas 
that appear. A VNC icon should now be present in the lower right task bar. VNC is primarily used for 
access to this machine when on the customer’s LAN.

LogMeIn must also be installed and linked to our Master Account for WAN support of this machine. 
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CLEANING UP
Make it a professional installation:

From the Distribution, copy the desktop pattern WebWorkstation Desktop2.jpg to the My Pictures folder 
located in My Documents on the target computer.

Right-click on the computer desktop and select this file as your desktop pattern.

Move all files remaining on the desktop to the Recycle Bin and empty it.

The only thing that should be left on your desktop is the Recycle Bin.
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