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NOTICES

NOTICE OF CONFIDENTIALITY

The contents of this document including all methods, descriptions, text, images, designs and operations 
displayed and/or described herein are proprietary and company confidential. No content of this document 
may be transmitted by verbal, written, electronic or any other method of communication to any person or 
entity outside of Precision Diagnostic Systems, Inc. Any unauthorized release of this information by any 
means is prohibited and punishable by law. This means you. 

Copyright 2009-2010 Precision Diagnostic Systems, Inc.

SCOPE OF THIS DOCUMENT

This document describes the procedure to build FastPACS WebWorkstation specifically on a computer 
running Windows XP and Internet Information Services version 5.1. This document only applies to 
WebWorkstation and does not apply for an installation of FastPACS on Windows Server 2003/2008 or 
other configurations. This document assumes the computer Operating System is already installed and 
configured.

Failure to execute these procedures in the order presented may produce unpredictable results.

Initial Release:! ! 7/2009
First Revision:! ! 9/2009
Second Revision:! 1/2010
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ARCHIVE INSTALLATION PART 1
From the latest Distribution, drag the bdinstall5 folder to the desktop of the target computer. Double-click 
the folder to open it and launch “Setup.exe” to install the Borland Database Engine. 

Note: There are two “setup” files in this folder. Launch the one with the computer icon, not the one with 
the icon of the globe. 

Accept the default values for the installation and allow the installation to finish:

Move the bdinstall5 folder from the desktop to the recycle bin.
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ARCHIVE INSTALLATION PART 1 (cont.)

From the latest Distribution, drag the “dicomserver1414” folder directly to the root of the C: drive of the 
target computer:

Open the C: drive and rename the folder “dicomserver1414” to “dicomserver”:

     

Open the c:\dicomserver folder and double-click ConquestDICOMServer:  

Click “OK” in the window that opens.
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ARCHIVE INSTALLATION PART 1 (cont.)

The server configuration window will now open.

Make the following changes:

* Change DICOM Server AETitle from CONQUESTSRV1 to FPSRV1
* Change TCP/IP Port Number from 5678 to 5680
* Under “Images on disk are stored:” Click on NKI compressed
* Under “Images on disk are named:” Click on V2 (allows NKI compression)
* Click in box “Keep Server Alive”
* Click the “Save configuration” button
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ARCHIVE INSTALLATION PART 1 (cont.)

The DICOM Server will now switch to the “Installation” Tab:

Do the following:

* Click “Verify TCP/IP installation”
* Click “Verify database installation”
* Click “(Re) initialize database
 

If no errors are present after doing each step outlined above, close the dicomserver window. This will quit 
the dicomserver application. Click “Yes” to the alert box:
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FASTPACS WEB SERVER INSTALLATION
Note:

The FastPACS Web Server requires installation of Microsoft Internet Information Services (IIS) and 
Microsoft .NET Frameworks Version 2.0. For proper functionality, IIS must be installed prior to the 
installation of Microsoft .NET Frameworks Version 2.0. However, on newer versions of XP, .NET 
Frameworks 2.0 is pre-installed which may cause issues with the proper binding of ASP.NET with IIS. 
Resolving this issue is described on the next page of this document.

INSTALL IIS:

Go to Start => Control Panel then double-click Add/Remove Programs:

   

On the left panel, click “Add/Remove Windows Components”:

  

In the window that opens, place a check mark by “Internet Information Services (IIS)” and click “Next”:

  

Note: You may be prompted to insert the Windows XP Installation disk.
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FASTPACS WEB SERVER INSTALLATION (cont.)

After installation of IIS is complete, go to Start => Control Panel => Administrative Tools => Internet 
Information Services. This launches the IIS Snap-in Control. 

Click the “+” next to the Computer Name then click the “+” next to Web Sites to reveal “Default Web Site”.

Right-click Default Web Site and select Properties (below left). Verify there is a tab for ASPNET present 
(below center). If so, select the ASPNET tab and see if it shows ASP.NET version 2.0xxxxx (below right):

    
If there is not an ASP.NET tab displayed or if it doesn’t by default specify version 2.0xxxxx you 
must repair/reinstall .NET Frameworks 2.0. To do this, locate and open the file dotnet repair.txt from 
the latest distribution. Highlight all text in this file and copy it (Cntl-C). Go to Start => Run. Enter cmd in 
the text entry box and press Enter to open a command line window. 

Right-click on the header of the command line window and choose Edit => Paste (below left). The text 
you have copied should be pasted into the command window (below right). Verify it is correct then press 
Enter to initiate the .NET repair process.

Allow the repair process to finish. You will receive an alert when it is done. Once done, reboot the 
computer then check for the presence of the ASP.NET tab that specifies version 2.0xxxxx using the IIS 
Snap-in Control as described above. 

For reference, following is the text that performs the .NET Frameworks 2.0 repair process:

msiexec /fpecmsu {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F} REINSTALL=ALL /l*v 
%temp%\netfx20sp2_repair_log.txt /qb
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FASTPACS WEB SERVER INSTALLATION (cont.)

From the latest Distribution, drag the “DIOWave” and “DIOWaveData” folders directly to the root of the C: 
drive of the target computer:

  

Click on “Start” then choose “Run” (below left). Type cmd in the window that opens (below right):

    

Type the following commands (shown in bold below) following the C:\> prompt in the DOS window that 
opens. Note that there is no space between “binPath” and “=”:

sc.exe create "DIO_STORAGE" binPath= "C:\DIOWave\bin\dio-storage.exe"
(It should respond "[SC] CreateService SUCCESS")
sc.exe start "DIO_STORAGE"
(It should respond with the Service Name and other info)

Your window should look similar to the following:

  
You have created the service that allows the FastPACS Web Server to receive DICOM images. You may 
close the window.
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FASTPACS WEB SERVER INSTALLATION (cont.)

Now set the service you have just created to automatically start upon boot and recover from errors:

Go to Start => Control Panel => Administrative Tools => Services.

Locate “DIO_STORAGE” in the list, right-click it and choose Properties:

Under the General tab, change Startup Type to Automatic (below left). Then select the Recovery tab 
(below right) and change the setting of First Failure, Second Failure and Subsequent Failures from “Take 
No Action” to “Restart The Service”:

Click “Apply” then click “OK”. Close out the open windows.
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FASTPACS WEB SERVER INSTALLATION (cont.)

Go to Start => Control Panel => Folder Options

Click the “View” tab and Deselect both “Hide extensions for known file types” and “Use simple file sharing 
(Recommended)”:

Click “Apply” then “OK” and close the open windows.
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FASTPACS WEB SERVER INSTALLATION (cont.)

Go to Start => Control Panel => Administrative Tools => Internet Information Services to launch the IIS 
Snap-in Control. 

Click the “+” next to the Computer Name then click the “+” next to Web Sites to reveal “Default Web Site”.

Right-click Default Web Site and navigate to New => Virtual Directory:

This creates /DIOWave = C:\DIOWave\wwwroot (Read document)

Enter Alias DIOWave
Enter Physical Path c:\DIOWave\wwwroot
Set the following access permission: Read
Right-click on DIOWave, select Properties to check the property sheet as below:
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FASTPACS WEB SERVER INSTALLATION (cont.)

Right click on DIOWave and navigate to New => Virtual Directory:

This creates /DIOWave/scripts = C:\DIOWave\scripts (Executable for ISAPI)

Enter Alias scripts
Enter Physical Path c:\DIOWave\scripts
Set the following access permission: Execute
Right click on scripts, select Properties, set application protection to Low (IIS Process):
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FASTPACS WEB SERVER INSTALLATION (cont.)

Right click on DIOWave and navigate to New => Virtual Directory:

This creates /DIOWave/StudyBrowser.NET = C:\DIOWave\webapp\StudyBrowser.Net (Executable for 
scripts)

Enter Alias StudyBrowser.NET
Enter Physical Path c:\DIOWave\webapp\StudyBrowser.NET
Set the 2 following access permissions: Read, Run Scripts
Right-click on StudyBrowser.NET, select Properties, set application protection to High (Isolated):

Close open windows and exit the IIS Snap-in Control
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FASTPACS WEB SERVER INSTALLATION (cont.)

In Windows explorer go to C:\DIOWave, right-click on the folder and select Properties.

Select the Security Tab then click Add to add the following users and give them Modify access rights:

ASPNET
IUSR_MACHINE NAME (where MACHINE NAME is the name of the computer)

  

Click “Apply” then click “OK”. 

Important Note: If the user ASPNET cannot be added, it indicates a problem with .NET Frameworks 2.0. 
You then must return to the repair process on page 9 and repair it. Bummer.

Now do the same process as above for the folder at C:\DIOWaveData

Go to Start => Control Panel => Administrative Tools => Internet Information Services to launch the IIS 
Snap-in Control.

REDIRECT HOME DIRECTORY: !
a) Right click on Default Web Site & choose Properties
b) Select the Home Directory tab
c) "A directory located on this computer" should be checked
d) Click BROWSE then navigate to c\diowave\webapp\studybrowser.net
e) Click OK

SET DEFAULT DOCUMENT:
a) Right click on StudyBrowser.NET & choose Properties
b) Select the Documents tab
c) See that Enable Default Document is checked
d) Click ADD then type "default.aspx"
e) Move default.aspx to the top of the list, then click Apply

When finished, close out all open windows and Reboot the computer.
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FASTPACS WEB SERVER INSTALLATION (cont.)

Launch Internet Explorer and go to http://localhost

If all goes well you should see this:

Quit Internet Explorer and go to c:\DIOWave\webapp\StudyBrowser.NET

Open query.aspx then press Cntl-F to open a “find” window and search for fastpacs

Upon the second occurrence of fastpacs, highlight the words FastPACS Web: 

Replace this text with the name of the customer’s institution:

Now save the document.
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iQ-VIEW INSTALLATION
Launch the iQ-VIEW installer from the desktop of the target computer. Accept the defaults for the 
installation EXCEPT CHANGE THE PORT FROM 104 TO 4000.

With iQ-VIEW running, select the “Network” tab and click the icon in the upper right hand corner that 
appears as 3 networked computers (below left). In the window that opens, single-click to highlight the first 
entry (below right):

  

Enter the new values in the lower part of the window:

Logical Name: ARCHIVE
DICOM AE Title: FPSRV1
IP Address: 127.0.0.1
Port Number: 5680

Click “Change” then click “Save”. You may now quit iQ-VIEW.

Go to C:\Program Files\iQ-VIEW then right-click on iQ-VIEW.exe and select “Pin to Start Menu”. Go to the 
Start Menu and right-click on “iQ-VIEW.exe” and rename this file “iQ-VIEW”.

Go to Start => All Programs => Startup and right-click on Startup. Choose Open. This will open a new 
window. Return to the C:\Program Files\iQ-VIEW window. Right-click and drag on iQ-VIEW.exe and 
move your mouse to the Startup window. Release the right mouse button and choose to place a shortcut 
in the location.

Open the file custom.ini located at C:\Program Files\iQ-VIEW with Notepad. Navigate to the line that 
begins with StudyBrowserForm.StudyGrid.Lines[15]. Remove all text to the right of the equal (=) sign then 
save the file and close it.
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ARCHIVE INSTALLATION PART 2
Navigate to C:\dicomserver and double-click the file dicom.ini (NOT dicom.sql)

Insert the following text at the end of this file:

IMPORTANT: Be sure there is a space both before and after the equal sign (=).

Your file should look like this:

Save the file and close it.

Double-click ConquestDICOMServer.exe:

Select the “Known DICOM Providers” tab:

Remove any existing entries and enter the following:

# Forwarding
ExportConverters!  = 2
ExportConverter0!  = FORWARD TO DIO_STORAGE
ExportConverter1!  = FORWARD TO IQSERVER

IgnoreOutOfMemoryErrors! = 1

FPSRV1! ! ! 127.0.0.1! 5680! ! un
DIO_STORAGE!! ! 127.0.0.1! 104! ! un
IQSERVER! ! ! 127.0.0.1! 4000! ! un
*! ! ! ! *! ! *! ! un
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ARCHIVE INSTALLATION PART 2

The “Known DICOM Providers” window should look like this:

When done, click “Save This List”. 

Now select the “Configuration” tab.

Click the button “Install Server as NT Service” as shown below. Wait several seconds to allow the 
AETitle entry to gray out while a service is being created:

Close the server window. Click “Yes” at the subsequent dialog box.
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ARCHIVE INSTALLATION PART 2

Go to Start => Control Panel => Administrative Tools => Services.

Right-click on FPSRV1 in the Services list and choose Properties.

Click the “Recovery” tab and change each entry to “Restart the Service”:

Click “Apply” then click “OK”. Close the open windows.

Reboot the computer.
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INSTALLATION OF HELPER APPLICATIONS

MICROSOFT ACCESS AND EXCEL

Now that the Core Applications have been installed, there are several additional applications that must be 
installed and configured.

Insert the Microsoft Office disk, Install Office 2003 (below left), then choose “Custom Install (below right):

    

De-select all items except Access and Excel then click “Next” to proceed with the installation:

Allow the installer to finish then remove the CD.
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DICOM PING

From the Distribution, drag the DICOM Ping folder to the root of the C: drive of the target computer:

Navigate to the folder C:\DICOM Ping and right-click on DICOMPing.exe and choose “Pin to Start Menu”: 

Go to Start then right-click on “DICOMPing.exe” and select “Rename”. Rename this file “DICOM Ping”
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JETCU40

JETCU40 is an Application for compacting the FastPACS Web MDB Database.

From the Distribution drag jetcu40.exe to the desktop of the target computer, then double-click to launch.

Click “Browse”

 

Expand “DIOWave” then single-click to highlight “db”. Click “OK”:

  

Click “OK” at the next window:

Installation is nearly instantaneous. Click “OK” when it is finished:
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IIS60RKT

IIS60RKT (IIS 6.0 Resource Kit) is a suite of tools to enhance Internet Information Services (IIS). SelfSSL 
is the only tool installed from this suite. This tool installed will allow creation of a Self-Signed Certificate to 
permit secure, 128-bit encrypted communication between web users and the FastPACS Web Server.

From the Distribution drag iis60rkt.exe to the desktop of the target computer, then double-click to launch.

Click “Next” to continue:

Agree to the License Agreement and fill in the user info on the next two screens.

Choose “Custom Installation” (below left) then accept the default location and click “Next” (below right):

  

De-select all items in the list except SelfSSL 1.0 then click “Next” to proceed and finish the installation:
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CREATE A SECURE SELF-SIGNED CERTIFICATE

Go to Start => All Programs => IIS Resources => SelfSSL => SelfSSL:

This will open a command prompt window. Type in the following text:

selfssl.exe /N:CN=PRECISION /V:1095

Note: You may insert the name of the customer’s institution instead of the text PRECISION as shown 
above. Note that no spaces are allowed (i.e. XYZ IMAGING CENTER becomes XYZ_IMAGING_CENTER).

Press “Y” and Enter when asked if you want to replace the SSL settings for site 1.

You should receive a message that “The self signed certificate was successfully assigned to site 1”. If you 
get a message that indicates an error, it invariably is due to mistyping. Re-enter the text again and be 
careful to insert spaces exactly where shown above.

Your screen should look like this

Close the command prompt window and go to Start => Control 
Panel => Administrative Tools => Internet Information Services. 
Click “+” next to the Computer Name, then click “+” next to 
Web Sites. Right-click on Default Web Site, choose 
“Properties”. Verify that there is an entry of 443 in the SSL Port 
box.

Change “Connection Timeout” from 900 to 180. Be sure HTTP 
Keep-Alives Enabled is checked.

Click “Apply” then “OK”. Close the window.
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DICOMREADER

Launch the DICOMREADER Installer, accept the default settings, and proceed with the installation:

When the installation is finished, click on the settings tool (it appears as a wrench):

Place check marks next to “start application minimized (as tray icon)” and “ask for new patient data”:
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DICOMREADER (cont.)

Click the DICOM Stations button:

Enter the password: DICOMREADER (in CAPS)

Click “Add” to add a new DICOM destination

Now enter the information for the WebWorkstation Archive:

Alias:! ! ARCHIVE
AETitle:!! FPSRV1
Address:! 127.0.0.1
Port:! ! 5680

  

Click “OK” when finished.
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DICOMREADER (cont.)

Select “ARCHIVE” from the drop-down menu as the default destination then click “OK”:

  

Minimize the DICOMREADER window (below left), then exit DICOMREADER by right-clicking the disk 
icon in the right area of the task bar (below right). Only when you quit DICOMREADER in this manner 
after the initial installation does it permanently save your settings:

  

Go to C:\Program Files\DICOMReader then right-click and drag on DICOMReader.exe. Release and 
select to create a shortcut in this same directory. Right-click on the shortcut and select “Pin to Start 
Menu”. Go to the Start Menu and right-click on “Shortcut to DICOMReader.exe” and rename this file 
“DICOMReader”.

Go to Start => All Programs => Startup and right-click on Startup. Choose Open. This will open a new 
window. Return to the C:\Program Files\DICOMReader window. Right-click and drag on the 
DICOMReader shortcut you have created there and move your mouse to the Startup window. Release 
your right mouse button and choose to copy this file there.
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DAILY BACKUP

This is an application that runs as a Scheduled Task to perform daily backups of the Archive and Web 
databases. This makes recovery easier and less painful in the event of database corruption.

From the Distribution, drag the Daily Backup folder to the root of the C: drive of the target computer:

Navigate to c:\Daily Backup\Bin\ and open the system.ini file by double-clicking on it.

Check that the last two lines of this file read precisely as follows:

c:\DIOWave\db\ = c:\DIOWaveBackup\db\@Weekday\
c:\dicomserver\data\dbase = c:\dicomserverBackup\data\@weekday\

If they do not, change them to read as above.

Close the open windows.

Now Daily Backup must be configured to run as a Windows Scheduled Task.

Go to Start => Control Panel => Scheduled Tasks and double-click “Add Scheduled Task”

Click “Next” (below left), then click “Browse” (below right):
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DAILY BACKUP (cont.)

Navigate to c:\Daily Backup\Bin and single-click to highlight “DailyBackup.exe”. Click “Open”:

Choose to perform this task daily (below left) and designate an appropriate time-of-day (below right):

  

Enter the password of the user of this machine (see “Schedule Task Problems” on next page regarding 
a potential issue with this). Then click “Finish”:
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DAILY BACKUP (cont.): 

Right-click on the Daily Backup Scheduled Task and choose “Run” to test that it works. If successful, the 
column “Last Run Time” should display the current time:

Scheduled Task Problems:

Windows XP with Service Pack 3 has a known issue when attempting to create a Scheduled Task 
wherein it will reject your password and not run the task. If you receive a message stating that the 
Scheduled Task may not run because of problems with your permissions use the following workaround:

* Delete the Scheduled Task you’ve just created by right-clicking on the task and choose “Delete”.
* Create the task again but use NT AUTHORITY\SYSTEM as the USER. No password is necessary.
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OTHER ITEMS

Adobe Reader.

From the Distribution or via direct download, Install Adobe Reader 9 on the target system. After 
installation, check for proper launch of Adobe Reader by launching iQ-VIEW then clicking on the help icon 
on the main screen:

Adobe Reader should launch. Accept the Adobe Reader license agreement. The iQ-VIEW User Guide 
should now be displayed. Quit iQ-VIEW. Then delete the Adobe Reader and acrobat shortcuts that have 
been deposited on the desktop.

Power Settings.

Go to Start => Control Panel => Power Options and set the system to Never Hibernate and Never 
Standby. Hard Drives should be set to Never Turn Off. The monitor should be set to power save after 10 
minutes. The selected Screen Saver should be “None”.

Remote Access.

Launch Internet Explorer and navigate to www.realvnc.com. Download the free version of the Windows 
executable. After downloading, launch the installer and accept the default settings. At the end of the 
installation click the “Configure” button and type pdsisupport as the password in the two entry areas 
that appear. A VNC icon should now be present in the lower right task bar. VNC is primarily used for 
access to this machine when on the customer’s LAN.

LogMeIn must also be installed and linked to our Master Account for WAN support of this machine. 
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CLEANING UP
Make it a professional installation:

From the Distribution, copy the desktop pattern WebWorkstation Desktop2.jpg to the My Pictures folder 
located in My Documents on the target computer.

Right-click on the computer desktop and select this file as your desktop pattern.

Move all files remaining on the desktop to the Recycle Bin and empty it.

The only thing that should be left on your desktop is the Recycle Bin.
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